Can't update CAS fx-cp400

Discuss anything related to calculators. For specific help on certain games/programs check the Released Projects subforum.
Junior Member
Posts: 1
Joined: Wed May 22, 2019 2:18 pm
Calculators: Casio Classpad fx-CP400

Can't update CAS fx-cp400

Postby Ruuku » Wed May 22, 2019 2:58 pm

Hey guys,

my CAS fx-cp400 is on version 2.1.0 and I want to update it to version 2.1.5
When I try to update the CAS, the program always says "Update Failed". I have followed the online instructions that Casio provide to try and update it.
When I connect my CAS to my Mac it doesn't show up as a device that has connected to the Mac. I've also tried updating it on a Windows computer but it still doesn't show up as a device or drive.

If you know any solution or anything that might help me, please reply.

Thank you!

Senior Member
Posts: 113
Joined: Mon Mar 02, 2015 10:53 am
Calculators: Casio fx-CG20

Re: Can't update CAS fx-cp400

Postby AmazoNKA » Fri May 31, 2019 9:10 pm

Perhaps the cable is at fault- have you tried other cables?

Posts: 45
Joined: Wed Jul 24, 2013 3:33 am
Calculators: Casio fx-7400GII (SH4), Casio fx-9750GII (SH4), Casio fx-9860GII SD, Casio Classpad 330, Casio fx-CG50, Casio Classpad fx-CP400

Re: Can't update CAS fx-cp400

Postby critor » Fri Jun 21, 2019 11:01 pm

I also have issues updating my fx-CP400 each time Casio releases an update.

On my regular computer it never works.
After confirming, the updater reports 'Failed' after a moment without further information, or more rarely "Wrong device".

No problem though with another computer, or with the fx-9860GII / fx-CG50 updates.

It seems I'm not the only one, I don't understand what's so special with the fx-CP400 updater.

Return to General

Who is online

Users browsing this forum: No registered users and 5 guests